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Chapter 1. General Information

1.1. Introduction

This document describes how to install OMNeT + + on various platforms. One chapter
is dedicated to each operating system.

1.2. Supported Platforms

OMNEeT + + has been tested and is supported on the following operating systems:

e Windows 7, Vista, XP

e Mac OS X 10.6 and 10.7

¢ Linux distributions covered in this Installation Guide

The Simulation IDE can be used on the following platforms:

¢ Linux x86

* Windows 7, Vista, XP

* Mac OS X 10.6 and 10.7

TE
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Simulations can be run practically on any unix-like environment with a decent and
fairly up-to-date C++ compiler, for example gcc 4.x. Certain OMNeT+ + features
(Tkenv, parallel simulation, XML support, etc.) depend on the availability of external
libraries (Tcl/Tk, MPI, LibXML or Expat, etc.)

IDE platforms are restricted because the IDE relies on a native shared library, which
we compile for the above platforms and distribute in binary form for convenience.




Chapter 2. Windows

2.1. Supported Windows Versions

The supported Windows versions are the Intel 32-bit versions of Windows XPF, and later
Windows versions such as Vista and Windows 7.

2.2. Installing OMNeT+ +

Download the OMNeT + + source code from http://omnetpp.org. Make sure you select
the Windows-specific archive, named ommet pp- 4. 2. 2- sr c- wi ndows. zi p.

The package is nearly self-contained: in addition to OMNeT + + files it includes a C++
compiler, a command-line build environment, and all libraries and programs required
by OMNeT + +.

Copy the OMNeT++ archive to the directory where you want to install it. Choose
a directory whose full path does not contain any space; for example, do not put
OMNeT+ + under Program Files.

Extract the zip file. To do so, right-click the zip file in Windows Explorer, and select
Extract All from the menu. You can also use external programs like Winzip or 7zip.
Rename the resulting directory to ormet pp- 4. 2. 2.

When you look into the new omrmet pp- 4. 2. 2 directory, should see directories named
doc, i mages, i ncl ude, nsys, etc., and files named m ngwenv. cnd, confi gure,
Makef i | e, and others.

2.3. Configuring and Building OMNeT + +

Start mi ngwenv. cnd in the onmet pp- 4. 2. 2 directory by double-clicking it in Windows
Explorer. It will bring up a console with the MSYS bash shell, where the path is already
set to include the ormet pp- 4. 2. 2/ bi n directory.

e If you want to start simulations from outside the shell as well (for example from
= Explorer), you need to add OMNeT+ +'s bi n directory to the path; instructions are
o provided later.

First, check the contents of the confi gure. user file to make sure it contains the
settings you need. In most cases you don’t need to change anything.

not epad confi gure. user
Then enter the following commands:

$ ./configure
$ make

The build process will create both debug and release binaries.

2.4. Verifying the Installation

You should now test all samples and check they run correctly. As an example, the dyna
example is started by entering the following commands:
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$ cd sanpl es/ dyna
$ ./dyna

By default, the samples will run using the graphical Tkenv environment. You should
see GUI windows and dialogs.

2.5. Starting the IDE

OMNeT++ comes with an Eclipse-based Simulation IDE. You should be able to start
the IDE by typing:

$ ommet pp

We recommend that you create a shortcut for starting the IDE. To do so, locate the
ommet pp. exe program in the ommet pp- 4. 2. 2/ i de directory in Windows Explorer,
right-click it, and choose Send To > Desktop (create shortcut) from the menu. On
Windows 7, you can right-click the taskbar icon while the IDE is running, and select
Pin this program to taskbar from the context menu.

When you try to build a project in the IDE, you may get the following warning message:

Toolchain "..." is not supported on this platform or installation. Please
go to the Project menu, and activate a different build configuration. (You
may need to switch to the C/C+ + perspective first, so that the required
menu items appear in the Project menu.)

If you encounter this message, choose Project > Properties > C/C++ Build > Tool
Chain Editor > Current toolchain > GCC for OMNeT+ +.

2.6. Environment Variables

If you want to start OMNeT + + simulations outside the shell as well (for example from
Exlorer), you need to add OMNeT+ +'s bi n directory to the path.

First, open the Environment Variables dialog.

* On Windows XP and Vista: Right-click My Computer, and choose Properties >
Advanced > Environment variables.

* On Windows 7: Click the Start button, then start typing envi ronnent vari abl es
into the search box. Choose Edit environment variables for your account when it
appears in the list. The dialog comes up.

In the dialog, select path or PATH in the list, click Edit. Append "; <ommet pp-
di r >\ bi n" to the value (without quotes), where <ommet pp- di r > is the name of the
OMNeT+ + root directory (for example C. \ ormet pp- 4. 2. 2). Hit Enter to accept.

You need to close and re-open any command windows for the changes to take effect
in them.

2.7. Reconfiguring the Libraries

If you need to recompile the OMNeT+ + components with different flags (e.g. different
optimization), then change the top-level OMNeT+ + directory, edit confi gure. user
accordingly, then type:

$ ./configure
$ make cl ean
$ make
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If you want to recompile just a single library, then change to the directory of the library
(e.g. cd src/sim and type:

$ make cl ean
$ make

By default, libraries are compiled in both debug and release mode. If you want to make
release or debug builds only, use:

$ make MODE=r el ease
or
$ make MODE=debug

By default, shared libraries will be created. If you want to build static libraries, set
SHARED LI BS=no in confi gur e. user and re-configure your project.

— The built libraries and programs are immediately copied to the |ib/ and bi n/
= subdirs.

2.8. Portability Issues

OMNeT++ has been tested with the MinGW gcc compiler. The current distribution
contains gcc version 4.6.

Microsoft Visual C+ + is not supported in the Academic Edition.

2.9. Additional Packages

Note that Doxygen and GraphViz are already included in the OMNeT + + package, and
do not need to be downloaded.

2.9.1. MPI

MPI is only needed if you would like to run parallel simulations.

There are several MPI implementations for Windows, and OMNeT++ does not
mandate any specific one. We recommend DeinoMPI, which can be downloaded from
http://mpi.deino.net.

After installing DeinoMPI, adjust the MPI_DIR setting in OMNeT++'s
confi gure. user, and reconfigure and recompile OMNeT + +:

$ ./configure
$ nmake cl eanal |

$ make
" In general, if you would like to run parallel simulations, we recommend that you use
= Linux, OS X, or another unix-like platform.
2.9.2. PCAP

The optional WinPcap library allows simulation models to capture and transmit
network packets bypassing the operating system’s protocol stack. It is not used directly
by OMNeT++, but OMNeT+ + detects the necessary compiler and linker options for
models in case they need it.
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2.9.3. Akaroa

Akaroa 2.7.9, which is the latest version at the time of writing, does not support
Windows. You may try to port it using the porting guide from the Akaroa distribution.




Chapter 3. Mac OS X

3.1. Supported Releases

This chapter provides additional information for installing OMNeT+ + on Mac OS X.
The following releases are covered:

* Mac OS X 10.6 (Snow Leopard)

* Mac OS X 10.7 (Lion)

They were tested on the following architectures:

* Intel 32/64-bit

3.2. Installing the Prerequisite Packages
Mac OS X 10.6 (Snow Leopard)

* Install Xcode 3.2.x on your machine. It can be downloaded from http:/
developer.apple.com/xcode/.

Mac OS X 10.7 (Lion)
* Install Xcode 4.3 or later on your machine. It can be downloaded from the App Store.

* You MUST activalte command line support by starting XCode and installing Conmand
Li ne Tool s from Xcode | Preferences | Downl oads | Conponents.

* Install the Java Runtime from http://support.apple.com/kb/DL1421 , because OS X
Lion does not provide it by default.

Installing additional packages will enable more functionality in OMNeT ++; see the
Additional packages section at the end of this chapter.

3.3. Downloading and Unpacking OMNeT + +

Download OMNeT + + from http://omnetpp.org. Make sure you select to download the
generic archive, ormet pp-4. 2. 2-src. tgz.

Copy the archive to the directory where you want to install it. This is usually your home
directory, / User s/ <you>. Open a terminal, and extract the archive using the following
command:

$ tar zxvf ommetpp-4.2.2-src.tgz

A subdirectory called ommet pp- 4. 2. 2 will be created, containing the simulator files.

Alternatively, you can also unpack the archive using Finder.

OTE The Terminal can be found in the Applications / Utilities folder.
W
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3.4. Environment Variables

OMNeT+ + needs its bi n/ directory to be in the path. To add bi n/ to PATHtemporarily
(in the current shell only), change into the OMNeT ++ directory and source the set env
script:

$ cd omet pp-4.2.2
$ . setenv

To set the environment variables permanently, edit . bashr ¢ in your home directory.
Use your favourite text editor to edit . bashr c, for example TextEdit:

$ touch ~/.bashrc
$ open -e ~/.bashrc

t ouch is needed because open - e only opens existing files. Alternatively, you can use
NOTE '
= the terminal-based pico editor (pi co ~/. bashrc)

Add the following line at the end of the file, then save it:
export PATH=$PATH: $HOVE/ ommet pp-4. 2. 2/ bin
You need to close and re-open the terminal for the changes to take effect.

Alternatively, you can put the above line into ~/ . bash_pr ofi | e, but then you need to
log out and log in again for the changes to take effect.

OTE If you use a shell other than the default one, bash, consult the man page of that shell
= to find out which startup file to edit, and how to set and export variables.

3.5. Configuring and Building OMNeT + +

Check confi gur e. user to make sure it contains the settings you need. In most cases
you don’t need to change anything in it.

In the top-level OMNeT + + directory, type:
$ ./configure

The confi gur e script detects installed software and configuration of your system.
It writes the results into the Makefi | e. i nc file, which will be read by the makefiles
during the build process.

Normally, the conf i gur e script needs to be running under the graphical environment
in order to test for wi sh, the Tcl/Tk shell. If you are logged in via an ssh session or you
want to compile OMNeT + + without Tcl/Tk, use the command

$ NO TCL=1 ./configure

instead of plain . / confi gure.

If there is an error during confi gur e, the output may give hints about what went
wrong. Scroll up to see the messages. (You may need to increase the scrollback buffer
size of the terminal and re-run . / confi gur e.) The script also writes a very detailed
log of its operation into confi g. | og to help track down errors. Since confi g. | og is
very long, it is recommended that you open it in an editor and search for phrases like
error or the name of the package associated with the problem.

TE
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Mac OS X

OMNEeT+ + builds without the BLT Tcl/Tk extension, because BLT is not available for

TE
2CS the native (Aqua) version of Tcl/Tk.

As an alternative to the Aqua version of Tcl/Tk, you may also use the X11 version from
the MacPorts repository (http://macports.org). The MacPorts version does not have
the look and feel of OS X applications, but it may provide better performance with
animations. To select the MacPorts version of Tk, you will need to adjust the Tcl/Tk
settings in OMNeT++'s confi gur e. user file and re-run the ./ confi gur e. Please
note that we do not provide support for using the MacPorts version of Tcl/Tk.

When . / conf i gur e has finished, you can compile OMNeT+ +. Type in the terminal:

$ nmake

O To take advantage of multiple processor cores, add the -j 2 option to the nmake
= command line.

The build process will not write anything outside its directory, so no special privileges
are needed.

O The make command will seemingly compile everything twice. This is because both
=1 debug and optimized versions of the libraries are built. If you only want to build one
set of the libraries, specify MODE=debug or MODE=r el ease:

$ make MODE=r el ease

3.6. Verifying the Installation

You can now verify that the sample simulations run correctly. For example, the dyna
simulation is started by entering the following commands:

$ cd sanpl es/ dyna
$ ./dyna

By default, the samples will run using the Tcl/Tk environment. You should see nice gui
windows and dialogs.

3.7. Starting the IDE

OMNeT++ comes with an Eclipse-based Simulation IDE. Mac OS X 10.6 already has
Java installed, so you do not need to install it. On Mac OS X 10.7 (Lion), the Java
Runtime must be installed (see prerequisites) before you can use the IDE. Start the

IDE by typing:
$ omet pp

If you would like to be able to launch the IDE via Applications, the Dock or a desktop
shortcut, do the following: open the ormet pp- 4. 2. 2 folder in Finder, go into the i de
subfolder, create an alias for the omnetpp program there (right-click, Make Alias), and
drag the new alias into the Applications folder, onto the Dock, or onto the desktop.

Alternatively, run one or both of the commands below:

$ make install-nmenu-item
$ make install-desktop-icon

which will do roughly the same.
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3.8. Using the IDE

When you try to build a project in the IDE, you may get the following warning message:

Toolchain "..." is not supported on this platform or installation. Please
go to the Project menu, and activate a different build configuration. (You
may need to switch to the C/C+ + perspective first, so that the required
menu items appear in the Project menu.)

If you encounter this message, choose Project > Properties > C/C++ Build > Tool
Chain Editor > Current toolchain > GCC for OMNeT+ +.

The IDE is documented in detail in the User Guide.

3.9. Reconfiguring the Libraries

If you need to recompile the OMNeT ++ components with different flags (e.g. different
optimization), then change the top-level OMNeT+ + directory, edit confi gure. user
accordingly, then type:

$ ./configure
$ make cl ean
$ nmake

To take advantage of multiple processor cores, add the -j 2 option to the nmake
=1 command line.

If you want to recompile just a single library, then change to the directory of the library
(e.g. cd src/sim and type:

$ nmake cl ean
$ make

By default, libraries are compiled in both debug and release mode. If you want to make
release or debug builds only, use:

$ make MODE=r el ease
or
$ make MODE=debug

By default, shared libraries will be created. If you want to build static libraries, set
SHARED LI BS=no in confi gur e. user and re-configure your project.

The built libraries and programs are immediately copied to the |i b/ and bi n/

NOTE

= subdirectories.

OTE The Tcl/Tk environment uses the native Aqua version of Tcl/Tk, so you will see native
NOTE

widgets. However, due to problems in the Tk/Aqua port, you may experience minor Ul
quirks. We are aware of these problems, and are working on the solution.

3.10. Additional Packages
3.10.1. OpenMPI

* OpenMPI is already bundled with OS X 10.6, so you do not need to manually install it.
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3.10.2.

3.10.3.

3.10.4.

* OS X 10.7 does not come with OpenMPI, so you must install it manually. Download
it from http://open-mpi.org and follow the installation instructions. Alternatively, you
can install it from the MacPorts repo by typing sudo port install opennpi.
In this case, you have to manually set the MPI CFLAGS and MPI_LIBS variables
in confi gure. user and re-run ./ confi gure. Please note that we do not provide
support for OpenMPI installed from the MacPorts repository.

MacPorts is a repository of several open source packages for Mac OS X. Using MacPorts
= packages may save you some manual work. You can install MacPorts from http://
- WWW.macports.org.

GraphViz

GraphViz is needed if you want to have diagrams in HTML documentation that you
generate from NED files in the IDE (Generate NED Documentation... item in the
project context menu).

Download and install the GraphViz OS X binaries from http:/www.pixelglow.com/
graphviz/download/. Download the latest, version 2.x package; at the time of writing,
the link is at the top of the page.

Alternatively, you can install it from the MacPorts project by typing sudo port
i nstall graphviz.

After installation, make sure that the dot program is available from the command line.
Open a terminal, and type

$ dot -V

Note the capital V. The command should normally work out of the box. If you get the
"command not found" error, you need to put dot into the path. Find the dot program
in the GraphViz installation directory, and soft link it into / usr/ | ocal / bi n (sudo I n
-s <pat h>/dot /usr/!|ocal/bin).

Doxygen

Doxygen is needed if you want to generate documentation for C++ code, as part of
the HTML documentation that you generate from NED files in the IDE (Generate NED
Documentation... item in the project context menu).

Download the Doxygen OS X binaries from the Doxygen web site’s download page,
http://www.stack.nl/~dimitri/doxygen/download.html, and install it.

Alternatively, you can install it from the MacPorts project by typing sudo port
install doxygen.

After installation, ensure that the doxygen program is available from the command
line. Open a terminal, and type

$ doxygen

If you get the "command not found" error, you need to put doxygen into the path. Enter
into a terminal:

$ cd / Applications/ Doxygen. app/ Cont ent s/ Resour ces/
$ sudo I n -s doxygen doxytags /usr/local/bin

Akaroa

Akaroa 2.7.9, which is the latest version at the time of writing, does not support Mac
OS X. You may try to port it using the porting guide from the Akaroa distribution.

10
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Chapter 4. Linux

4.1. Supported Linux Distributions

This chapter provides instructions for installing OMNeT++ on selected Linux
distributions:

* Ubuntu 10.04 LTS, 11.04

* Fedora Core 15, 16

* Red Hat Enterprise Linux Desktop Workstation 5.5
* OpenSUSE 11.4

This chapter describes the overall process. Distro-specific information, such as how
to install the prerequisite packages, are covered by distro-specific chapters.

If your Linux distribution is not listed above, you still may be able to use some distro-
specific instructions in this Guide.

note
Ubuntu derivatives (Ubuntu instructions may apply):
* Kubuntu, Xubuntu, Edubuntu, ...

¢ Linux Mint

Some Debian-based distros (Ubuntu instructions may apply, as Ubuntu itself is based
on Debian):

* Knoppix and derivatives

* Mepis

Some Fedora-based distros (Fedora instructions may apply):
e Simplis

* Eeedora

4.2. Installing the Prerequisite Packages

OMNeT+ + requires several packages to be installed on the computer. These packages
include the C++ compiler (gcc), the Java runtime, and several other libraries and
programs. These packages can be installed from the software repositories of your Linux
distribution.

See the chapter specific to your Linux distribution for instructions on installing
the packages needed by OMNeT + +.

You may need superuser permissions to install packages.
Not all packages are available from software repositories; some (optional) ones need to

be downloaded separately from their web sites, and installed manually. See the section
Additional Packages later in this chapter.

11



Linux

4.3. Downloading and Unpacking

Download OMNeT + + from http://omnetpp.org. Make sure you select to download the
generic archive, oomet pp-4. 2. 2-src. tgz.

Copy the archive to the directory where you want to install it. This is usually your home
directory, / home/ <you>. Open a terminal, and extract the archive using the following
command:

$ tar xvfz ometpp-4.2.2-src.tgz

This will create an ormet pp- 4. 2. 2 subdirectory with the OMNeT + + files in it.

On how to open a terminal on your Linux installation, see the chapter specific to your
NOTE . e
= Linux distribution.

4.4. Environment Variables

OMNeT+ + needs its bi n/ directory to be in the path. To add bi n/ to PATHtemporarily
(in the current shell only), change into the OMNeT ++ directory and source the set env
script:

$ cd omet pp-4.2.2
$ . setenv

The script also adds the |i b/ subdirectory to LD LI BRARY_PATH, which may be
necessary on systems that don’t support the rpath mechanism.

To set the environment variables permanently, edit . bashr ¢ in your home directory.
Use your favourite text editor to edit . bashr c, for example gedit:

$ gedit ~/.bashrc

Add the following line at the end of the file, then save it:

export PATH=$PATH: $HOVE/ omrmet pp- 4. 2. 2/ bi n

You need to close and re-open the terminal for the changes to take effect.

Alternatively, you can put the above line into ~/ . bash_pr of i | e, but then you need to
log out and log in again for the changes to take effect.

If you use a shell other than bash, consult the man page of that shell to find out which

TE
A startup file to edit, and how to set and export variables.

Note that all Linux distributions covered in this Installation Guide use bash unless
the user has explicitly selected another shell.

4.5. Configuring and Building OMNeT + +

In the top-level OMNeT+ + directory, type:
$ ./configure

The confi gure script detects installed software and configuration of your system.
It writes the results into the Makefi | e. i nc file, which will be read by the makefiles
during the build process.

12
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i=] BNt @Bt ESREOP =) 2200 B EE
File Edit Wiew Terminal Tabs Help

checking for Akaroa with CFLAGS=" -02 -DNDEBUG=1 -fno-stack-protector  -DXMLPAR
SER=1libxml " LIBS=""... no
checking for Akaroa with CFLAGS=" -02 -DNDEBUG=1 -fno-stack-protector -DXMLPAR
SER=1ibxml " LIBS="-lakaroa -1fl"... no

configure: WARNING: Optional package Akaroa not found

configure: creating ./config.status

config.status: creating Makefile.inc

config.status: creating test/core/runtest

patching the ide configuration file. default workspace is: /home/ubuntu/omnest-4
.0/samples

[+]

WARNING: The configuration script could not detect the following packages:
MPI (optional) Akaroa (optional)
Scroll up to see the warning messages (use shift+PgUp key), and see config.log
for more details. While you can use OMNEST in the current
configuration, please be aware that some functionality may be unavailable
or incomplete.

Your PATH contains /home/ubuntu/omnest-4.8/bin. Good! —

TCL LIBRARY is set. Good!
ubuntu@ubuntu-desktop:~/omnest-4.0% I

Figure 4.1. Configuring OMNeT+ +

Normally, the conf i gur e script needs to be running under the graphical environment
(X11) in order to test for wi sh, the Tcl/Tk shell. If you are logged in via an ssh session,
or there is some other reason why X is not running, the easiest way to work around
the problem is to tell OMNeT+ + to build without Tcl/Tk. To do that, use the command

$ NO TCL=1 ./configure

instead of plain . / confi gure.

If there is an error during confi gur e, the output may give hints about what went
wrong. Scroll up to see the messages. (Use Shift+PgUp; you may need to increase the
scrollback buffer size of the terminal and re-run . / conf i gur e.) The script also writes
a very detailed log of its operation into confi g. | og to help track down errors. Since
confi g. | og is very long, it is recommended that you open it in an editor and search
for phrases like error or the name of the package associated with the problem.

NOTE

When . / conf i gur e has finished, you can compile OMNeT+ +. Type in the terminal:

$ nmake

13
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=1 Ve El sy Eie e slse g o f E2.0" =N =n =
File Edit Wiew Terminal Tabs Help

g++ -c -g -Wall -fno-stack-protector  -DXMLPARSER=Libxml -DWITH_PARSIM —DWITH_NKﬁ
ETBUILDER -I. -Ihtdocs -I/home/ubuntu/omnest-4.0/include -o out/gcc-debug//Http
Msg _m.o HttpMsg m.cc

g++ -C -g -Wall -fno-stack-protector  -DXMLPARSER=Libxml -DWITH PARSIM -DWITH N
ETBUILDER -I. -Ihtdocs -I/home/ubuntu/omnest-4.8/include -o out/gcc-debug//NetP
kt m.o NetPkt m.cc

g++ -c -g -Wall -fno-stack-protector  -DXMLPARSER=Libxml -DWITH PARSIM -DWITH N
ETBUILDER -I. -Ihtdocs -I/home/ubuntu/omnest-4.0/include -o out/gcc-debug//Teln
etPkt_m.o TelnetPkt m.cc

g++ -Wl,--export-dynamic -Wl,-rpath,/home/ubuntu/omnest-4.0/1ib:. -0 out/gcc-de
bug//sockets out/gcc-debug//Cloud.o out/gcc-debug//ExtHttpClient.o out/gcc-debu
g//ExtTelnetClient.o out/gcc-debug//HttpClient.o out/gcc-debug//HttpServer.o out
/gcc-debug//QueueBase.o out/gcc-debug//SocketRTScheduler.o out/gcc-debug//Telnet
Client.o out/gcc-debug//TelnetServer.o out/gcc-debug//HttpMsg m.o out/gcc-debug/
/NetPkt _m.o out/gcc-debug//TelnetPkt m.o -Wl,--whole-archive -Wl,--no-whole-ar
chive -L"/home/ubuntus/omnest-4.0/1ib/gcc” -L"/home/ubuntu/omnest-4.8/1ib" -u _tk
env_lib -lopptkenvd -loppenvird -lopplayoutd -u _cmdenv_lib -loppcmdenvd -loppen
vird -loppsimd -1dl -lstdc++

1n -s -f out/gcc-debug//sockets .

make[2]: Leaving directory " /home/ubuntu/omnest-4.0/samples/sockets’

make[1]: Leaving directory */home/ubuntu/omnest-4.@°

[»

Now you can type "omnest" to start the IDE
ubuntu@ubuntu-desktop:~/omnest-4.0%

Figure 4.2. Building OMNeT+ +

To take advantage of multiple processor cores, add the -j 2 option to the nake
@ command line.

The build process will not write anything outside its directory, so no special privileges

NOTE
— are needed.

debug and optimized versions of the libraries are built. If you only want to build one

@ The make command will seemingly compile everything twice. This is because both
set of the libraries, specify MODE=debug or MODE=r el ease:

$ make MODE=r el ease

4.6. Verifying the Installation

You can now verify that the sample simulations run correctly. For example, the dyna
simulation is started by entering the following commands:

$ cd sanpl es/ dyna
$ ./dyna

By default, the samples will run using the Tcl/Tk environment. You should see nice gui
windows and dialogs.

4.7. Starting the IDE

You can launch the OMNeT+ + Simulation IDE by typing the following command in
the terminal:

$ ommet pp

14



Linux
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Figure 4.3. The Simulation IDE

If you would like to be able to access the IDE from the application launcher or via a
desktop shortcut, run one or both of the commands below:

$ make install-nmenu-item
$ make install-desktop-icon

Or add a shortcut that points to the onmet pp program in the i de subdirectory by other
means, for example using the Linux desktop’s context menu.

4.8. Using the IDE

When you try to build a project in the IDE, you may get the following warning message:

Toolchain "..." is not supported on this platform or installation. Please
go to the Project menu, and activate a different build configuration. (You
may need to switch to the C/C+ + perspective first, so that the required
menu items appear in the Project menu.)

If you encounter this message, choose Project > Properties > C/C++ Build > Tool
Chain Editor > Current toolchain > GCC for OMNeT+ +.

The IDE is documented in detail in the User Guide.

4.9. Reconfiguring the Libraries

If you need to recompile the OMNeT ++ components with different flags (e.g. different
optimization), then change the top-level OMNeT++ directory, edit confi gure. user
accordingly, then type:

$ ./configure
$ make cl eanal |
$ nake

If you want to recompile just a single library, then change to the directory of the library
(e.g. cd src/sim and type:

$ make cl ean
$ nake

By default, libraries are compiled in both debug and release mode. If you want to make
release or debug builds only, use:
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4.10.

4.10.1.

4.10.2.

$ nmake MODE=rel ease
or
$ make MODE=debug

By default, shared libraries will be created. If you want to build static libraries, set
SHARED LI BS=no in confi gur e. user and re-configure your project.

= For detailed description of all options please read the Build Options chapter.
oIS

Additional Packages

Note that at this point, MPI, Doxygen and GraphViz have been installed as part of the
prerequisites.

Akaroa

Linux distributions do not contain the Akaroa package. It must be downloaded,
compiled and installed manually before installing OMNeT + +.

E As of version 2.7.9, Akaroa only supports Linux and Solaris.
WS

Download Akaroa 2.7.9 from: http://www.cosc.canterbury.ac.nz/research/RG/net_sim/
simulation_group/akaroa/download.chtml

Extract it into a temporary directory:
$ tar xfz akaroa-2.7.9.tar.gz

Configure, build and install the Akaroa library. By default, it will be installed into the
{usr/1 ocal / akar oa directory.

$ ./configure
$ make
$ sudo meke install

Go to the OMNeT++ directory, and (re-)run the confi gure script. Akaroa will be
automatically detected if you installed it to the default location.

PCAP

The optional Pcap library allows simulation models to capture and transmit network
packets bypassing the operating system’s protocol stack. It is not used directly by
OMNeT++, but OMNeT++ detects the necessary compiler and linker options for
models in case they need it.
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Chapter 5. Ubuntu

5.1. Supported Releases

This chapter provides additional information for installing OMNeT++ on Ubuntu
Linux installations. The overall installation procedure is described in the Linux
chapter.

The following Ubuntu releases are covered:

e Ubuntu 10.04 LTS

* Ubuntu 11.04

They were tested on the following architectures:

¢ Intel 32-bit and 64-bit

The instructions below assume that you use the Gnome desktop and the bash shell,

which are the defaults. If you use another desktop environment or shell, you may need
to adjust the instructions accordingly.

5.2. Opening a Terminal

Choose Applications > Accessories > Terminal from the menu.

This only applies if you use the Gnome Desktop (default).

5.3. Installing the Prerequisite Packages

You can perform the installation using the graphical user interface or from the terminal,
whichever you prefer.

5.3.1. Command-Line Installation

Before starting the installation, refresh the database of available packages. Type in the
terminal:

$ sudo apt-get update

To install the required packages, type in the terminal:

$ sudo apt-get install build-essential gcc g++ bison flex perl \
tcl-dev tk-dev blt |ibxm 2-dev zliblg-dev openjdk-6-jre \
doxygen graphvi z opennpi -bi n |i bopennpi-dev |ibpcap-dev

At the confirmation questions (Do you want to continue? [Y/N]), answer Y.
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Suggested packages:
bison-doc blt-demo cpp-doc gcc-4.2-locales debian-keyring g++-multilib
g++-4.2-multilib gcc-4.2-doc libstdc++6-4.2-dbg autoconf automakel.9 gcc-doc
gcc-multilib libtool manpages-dev gcc-4.2-multilib libgccl-dbg libgompl-dbg
libmudflap@-4.2-dev libmudflap@-dbg glibc-doc libstdc++6-4.2-doc diff-doc
libterm-readline-gnu-perl libterm-readline-perl-perl tclreadline tcl8.4-doc
tka.4-doc

Recommended packages:
perl-doc

The following NEW packages will be installed:
bison blt blt-dev build-essential dpkg-dev flex g++ g++-4.2 libc6-dev
libice-dev libpthread-stubs® libpthread-stubs@-dev libsm-dev
libstdc++6-4.2-dev Libtimedate-perl libx1l-dev libxau-dev Llibxcb-x1ib@-dev
libxcbl-dev libxdmcp-dev libxml2-dev libxt-dev linux-libc-dev m4 patch
tcl8.4 tcld.4-dev tk8.4 tk8.4-dev xllproto-core-dev xllproto-input-dev
x1lproto-kb-dev xtrans-dev zliblg-dev

The following packages will be upgraded:
cpp cpp-4.2 gcc gecc-4.2 gec-4.2-base libch 1ibc6-1686 Libffi4 libgecl
libgompl libperl5.8 libstdc++6 libxml2 perl perl-base perl-modules

16 upgraded, 34 newly installed, © to remove and 389 not upgraded.

Need to get 18.4MB/35.4MB of archives.

After this operation, 62.3MB of additional disk space will be used.

Do you want to continue [Y/n]? yfi

Figure 5.1. Command-Line Package Installation
5.3.2. Graphical Installation

Ubuntu’s graphical installer, Synaptic, can be started with the System >
Administration > Synaptic package manager menu item.

Since software installation requires root permissions, Synaptic will ask you to type
your password.

Search for the following packages in the list, click the squares before the names, then
choose Mark for installation or Mark for upgrade.

If the Mark additional required changes? dialog comes up, choose the Mark button.
The packages:

* build-essential, gcc, g+ +, bison, flex, perl, tcl-dev, tk-dev, blt, libxml2-deyv, zlib1lg-
dev, openjdk-6-jre, doxygen, graphviz, openmpi-bin, libopenmpi-dev, libpcap-dev
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Figure 5.2. Synaptic Package Manager

Click Apply, then in the Apply the following changes? window, click Apply again.
the Changes applied window, click Close.
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Chapter 6. Fedora 15 and 16

6.1. Supported Releases

This chapter provides additional information for installing OMNeT++ on Fedora
installations. The overall installation procedure is described in the Linux chapter.

The following Fedora releases are covered:
* Fedora 15 and 16
They were tested on the following architectures:

¢ Intel 32-bit and 64-bit

6.2. Opening a Terminal

Choose Applications > System Tools > Terminal from the menu.

6.3. Installing the Prerequisite Packages

You can perform the installation using the graphical user interface or from the terminal,
whichever you prefer.

6.3.1. Command-Line Installation
To install the required packages, type in the terminal:
$ su -c 'yuminstall make gcc gcc-c++ bison flex perl \
tcl-devel tk-devel blt |ibxm 2-devel zlib-devel \
j ava- 1. 6. 0-openj dk doxygen graphvi z opennpi -devel |ibpcap-devel’

then follow the instruction on the console.

Note that openmpi will not be available by default, it needs to be activated in every
session with the

$ nodul e | oad opennpi - <arch>
command, where <ar ch> is your architecture (usually i 386 or x86_64). When in
doubt, use nodul e avai |l to display the list of available modules. If you need MPI

in every session, you may add the nodul e | oad command to your startup script
(. bashrc).

6.3.2. Graphical Installation

The graphical installer can be launched by choosing System > Administration > Add/
Remove Software from the menu.
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Figure 6.1. Add/Remove Software

Search for the following packages in the list. Select the checkboxes in front of the
names, and pick the latest version of each package.

The packages:

* bison, gce, gee-c++, flex, perl, tcl-devel, tk-devel, blt, libxml2-devel, zlib-devel,
xulrunner, make, java-1.6.0-openjdk, doxygen, graphviz, openmpi-devel, libpcap-
devel

Click Apply, then follow the instructions.
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Chapter 7. Red Hat

7.1. Supported Releases

This chapter provides additional information for installing OMNeT++ on Red Hat
Enterprise Linux installations. The overall installation procedure is described in the
Linux chapter.

The following Red Hat release is covered:

* Red Hat Enterprise Linux Desktop Workstation 5.5

It was tested on the following architectures:

* Intel 32-bit

7.2. Opening a Terminal

Choose Applications > Accessories > Terminal from the menu.

7.3. Installing the Prerequisite Packages

You can perform the installation using the graphical user interface or from the terminal,
whichever you prefer.

= You will need Red Hat Enterprise Linux Desktop Workstation for OMNeT+ +. The
= Deslktop Client version does not contain development tools.

7.3.1. Command-Line Installation
To install the required packages, type in the terminal:

$ su -c 'yuminstall make gcc gcc-c++ bison flex perl \
tcl-devel tk-devel |ibxm 2-devel zlib-devel \
j ava- 1. 6. 0- openj dk doxygen opennpi -devel |ibpcap-devel"

then follow the instruction on the console.

Note that openmpi will not be available by default, it needs to be activated in every
session with the

$ nodul e | oad opennpi _<arch>
command, where <ar ch> is your architecture (usually i 386 or x86_64). When in

doubt, use nodul e avai |l to display the list of available modules. If you need MPI
in every session, you may add the nodul e | oad command to your startup script

(. bashrc).”
= Red Hat provides no BLT package, so it is missing from the above list. BLT is optional
oIS

in OMNeT++ and its absence will not result in loss of functionality, but you can
download a BLT source package from sourceforge.net, and compile and install it
yourself if you wish. See the Generic Unix chapter of this Installation Guide for more
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information on BLT. Alternatively you may search for binary RPM packages using
http://rpm pbone. net

GraphViz packages for RHEL can be installed from graphviz.org, see http:/
www.graphviz.org/Download_linux rhel.php. GraphViz is an optional package for
OMNEeT+ +; you only need it if you plan to generate HTML documentation from NED
files, and would like the resulting documentation to contain diagrams.

NOTE

7.3.2. Graphical Installation

The graphical installer can be launched by choosing Applications > Add/Remove
Software from the menu.

Search for the following packages in the list. Select the checkboxes in front of the
names, and pick the latest version of each package.

The packages:

* gce, gee-c++, bison, flex, perl, tcl-devel, tk-devel, libxml2-devel, zlib-devel, make,
java-1.6.0-openjdk, doxygen, openmpi-devel, libpcap-devel

Click Apply, then follow the instructions.

The above list does not contain BLT and GraphViz; see the previous section for more
NOTE
= info about these packages.

7.4. SELinux

You may need to turn off SELinux when running certain simulations. To do so, click
on System > Administration > Security Level > Firewall, go to the SELinux tab, and
choose Disabled.

You can verify the SELinux status by typing the sest at us command in a terminal.

From OMNeT+ + 4.1 on, makefiles that build shared libraries include the chcon -t
textrel _shlib_t |ib<name>. so command that properly sets the security context
for the library. This should prevent the SELinux-related "cannot restore segment prot
after reloc: Permission denied" error from occurring, unless you have a shared library
which was built using an obsolete or hand-crafted makefile that does not contain the
chcon command.

TE
NOE
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Chapter 8. OpenSUSE

8.1. Supported Releases

This chapter provides additional information for installing OMNeT+ + on openSUSE
installations. The overall installation procedure is described in the Linux chapter.

The following openSUSE releases are covered:
* openSUSE 11.4
They were tested on the following architectures:

¢ Intel 32-bit and 64-bit

8.2. Opening a Terminal

Choose Applications > System > Terminal > Terminal from the menu.

8.3. Installing the Prerequisite Packages

You can perform the installation using the graphical user interface or from the terminal,
whichever you prefer.

8.3.1. Command-Line Installation
To install the required packages, type in the terminal:

$ sudo zypper install nmake gcc gcc-c++ bison flex perl \
tcl-devel tk-devel Iibxm 2-devel zlib-devel \
java-1 6 _0-openjdk doxygen graphvi z opennpi -devel |ibpcap-devel \
nozi | | a- xul runner 192

then follow the instruction on the console.

Note that openmpi will not be available by default, first you need to log out and log in
again, or source your . prof i | e script:

$. ~/.profile

OpenSUSE provides no BLT package, so it is missing from the above list. BLT is
optional in OMNeT+ + and its absence will not result in loss of functionality, but you
can download a BLT source package from sourceforge.net, and compile and install it
yourself if you wish. See the Generic Unix chapter of this Installation Guide for more
information on BLT.

TE
noTE

8.3.2. Graphical Installation

The graphical installer can be launched by choosing Computer > Yast > System >
Software > Software Management from the menu.
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Figure 8.1. Yast Software Management

Search for the following packages in the list. Select the checkboxes in front of the
names, and pick the latest version of each package.

The packages:

* make, gcc, gee-c++, bison, flex, perl, tcl-devel, tk-devel, libxml2-devel, zlib-devel,
java-1 6 0-openjdk, doxygen, graphviz, openmpi-devel, libpcap-devel

Click Accept, then follow the instructions.
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Chapter 9. Generic Unix

9.1. Introduction

This chapter provides additional information for installing OMNeT++ on Unix-like
operating systems not specifically covered by this Installation Guide. The list includes
FreeBSD, Solaris, and Linux distributions not covered in other chapters.

= In addition to Windows and Mac OS X, the Simulation IDE will only work on
= Linux x86 32/64-bit platforms. Other operating systems (FreeBSD, Solaris, etc.) and
- architectures may still be used as simulation platforms, without the IDE.

9.2. Dependencies
The following packages are required for OMNeT+ + to work:

build-essential, GNU make, These packages are needed for compiling OMNeT + +

gee, g++, bison (2.x+), flex, and simulation models, and also for certain

perl OMNEeT + + tools to work. Some C+ + compilers other
than g+ +, for example the Intel compiler, will also be
accepted.

The following packages are strongly recommended, because their absence results in
severe feature loss:

Tcl/Tk 8.4 or later Required by the Tkenv simulation runtime
environment. You need the devel packages that
include the C header files as well. It is also possible
to compile OMNeT + + without Tcl/Tk (and Tkenv), by
turning on the NO_TCL environment variable.

BLT (2.4z) This is a Tk extension recommended for Tkenv. The
normal (non-devel) package suffices. This package
is optional in the sense that if it is missing, Tkenv
will be still fully functional, albeit it will have a less
sophisticated user interface.

LibXML2 or Expat Either one of these XML parsers are needed for
OMNeT++ to be able to read XML files. The devel
packages (that include the header files) are needed.
LibXML2 is the preferred one.

SUN JRE or OpendDK, The Java runtime is required to run the Eclipse-

version 5.0 or later based Simulation IDE. Other implementations, for
example Kaffe, have been found to have problems
running the IDE. You do not need this package if you
do not plan to use the Simulation IDE.

xulrunner This package is part of Firefox, and is needed by
the IDE to display documentation, styled tooltips and
other items.

The following packages are required if you want to take advantage of some advanced
OMNeT ++ features:
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GraphViz, Doxygen These packages are used by the NED documentation
generation feature of the IDE. When they are missing,
documentation will have less content.

MPI openmpi or some other MPI implementation is required to
support parallel simulation execution.

Akaroa Implements Multiple Replications In Parallel (MRIP).
Akaroa can be downloaded from the project’'s website.

Pcap Allows simulation models to capture and transmit network
packets bypassing the operating system’s protocol stack. It
is not used directly by OMNeT+ +, but OMNeT+ + detects
the necessary compiler and linker options for models in
case they need it.

The exact names of these packages may differ across distributions.

9.3. Determining Package Names

If you have a distro unrelated to the ones covered in this Installation Guide, you need
to figure out what is the established way of installing packages on your system, and
what are the names of the packages you need.

9.3.1. Tcl/Tk

Tecl/Tk may be present as separate packages (t cl and t k), or in one package (t cl t k).
The version number (e.g. 8.5) is usually part of the name in some form (85, 8. 5, etc).
You will need the development packages, which are usually denoted with the - dev or
- devel name suffix.

Troubleshooting:

If your platform does not have suitable Tcl/Tk packages, you may still use OMNeT+ + to
run simulations from the command line. To disable the graphical runtime environment
use:

$ NO TCL=yes ./configure

This will prevent the build system to link with Tcl/Tk libraries. This is required also if
you are installing OMNeT+ + from a remote terminal session.

By default, the confi gur e script expects to find the Tcl/Tk libraries in the standard
linker path (without any - Ldi r ect or y linker option) and under the standard names
(i.e. with the -1 t cl 8. 4 or - | t ¢l 84 linker option). If you have them in different places
or under different names, you have to edit conf i gur e. user and explicitly set TK_LI BS
there (see the Build Options chapter for further details).

If you get the error no display and DISPLAY environment variable not set, then youre
either not running X (the wi sh command, and thus . / confi gur e won’'t work just in
the console) or you really need to set the DI SPLAY variable (export DI SPLAY=:0.0
usually does it).

If you get the error: Tcl_Init failed: Can’t find a usable init.tcl...

The TCL_LI BRARY environment variable should point to the directory which contains
init.tcl.Thatis, you probably want to put a line like

export TCL_LIBRARY=/usr/lib/tcl 8.4

into your ~/ . bashrc.
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If you still have problems installing Tcl/Tk, we recommend visiting the OMNeT+ +
site’s wiki packages for further troubleshooting tips: http://www.omnetpp.org/pmwiki/
index.php?n=Main.TclTkRelatedProblems

9.3.2. BLT

BLT is not a supported package in all Unix distributions. If your distro does not have
it, then your can either use Tkenv without BLT (not a big problem), or download and
build BLT yourself.

You can get the source tarball, BLT2. 4z. t ar. gz from the Sourceforge BLT project
page, http://sourceforge.net/projects/blt.

Unpack the source tgz, change into its directory, then type . / confi gur e, then make
and meke install. (For the last step you'll need root privileges — you may need to
contact your sysadmin). If there’s any problem, refer to the | NSTALL file in the package.

You can try your installation by running bl t Wi sh, or running wi sh and typing
% package require BLT
in it.

If you don't have root privileges or you get an error during the build,
please check the following page: http://www.omnetpp.org/pmwiki/index.php?
n=Main.TclTkRelatedProblems

9.3.3. The Java Runtime

You need to install the Sun JRE or OpendDK. On Unix platforms other than Linux the
IDE is not supported so JRE is not required either. We have tested various other Java
runtimes (gcj, kaffe, etc.), and the IDE does not work well with them.

Java version 5.0 (i.e. JRE 1.5) or later is required.
9.3.4. MPI

OMNeT++ is not sensitive to the particular MPI implementation. You may use
OpenMPI, or any other standards-compliant MPI package.

9.4. Downloading and Unpacking

Download OMNeT + + from http:/omnetpp.org. Make sure you select to download the
generic archive, oomet pp-4. 2. 2-src. tgz.

Copy the archive to the directory where you want to install it. This is usually your home
directory, / hone/ <you>. Open a terminal, and extract the archive using the following
command:

$ tar xvfz ometpp-4.2.2-src.tgz

This will create an ormet pp- 4. 2. 2 subdirectory with the OMNeT+ + files in it.

9.5. Environment Variables

In general OMNeT + + requires that its bin directory should be in the PATH. You should
add a line something like this to your . bashrc:

$ export PATH=$PATH: $HOVE/ ommet pp- 4. 2. 2/ bin

You may also have to specify the path where shared libraries are loaded from. Use:
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$ export LD LI BRARY_PATH=$LD LI BRARY PATH: $HOVE/ ormet pp-4.2.2/1ib

If conf i gur e complains about not finding the Tcl library directory, you may specify it
by setting the TCL_LI BRARY environment variable.

= If you use a shell other than bash, consult the man page of that shell to find out which
= startup file to edit, and how to set and export variables.

9.6. Configuring and Building OMNeT + +

In the top-level OMNeT + + directory, type:
$ ./configure

The confi gure script detects installed software and configuration of your system.
It writes the results into the Makefi | e. i nc file, which will be read by the makefiles
during the build process.

r nbimtuEubuntirrdeskropt =fomnest=4.0" EIIEF
File Edit View Terminal Tabs Help

checking for Akaroa with CFLAGS=" -02 -DNDEBUG=1 -fno-stack-protector  -DXMLPAR[+|
SER=1ibxml " LIBS=""... no

checking for Akaroa with CFLAGS=" -02 -DNDEBUG=1 -fno-stack-protector  -DXMLPAR
SER=1ibxml " LIBS="-lakaroa -1fl"... no

configure: WARNING: Optional package Akaroa not found

configure: creating ./config.status

config.status: creating Makefile.inc

config.status: creating test/core/runtest

patching the ide configuration file. default workspace is: /home/ubuntu/omnest-4
.8/samples

WARNING: The configuration script could not detect the following packages:
MPI (optional) Akaroa (optional)
Scroll up to see the warning messages (use shift+PgUp key), and see config.log
for more details. While you can use OMNEST in the current
configuration, please be aware that some functionality may be unavailable
or incomplete.

Your PATH contains /home/ubuntu/omnest-4.08/bin. Good! —

TCL_LIBRARY is set. Good!
ubuntu@ubuntu-desktop:~/omnest-4.05 |

Figure 9.1. Configuring OMNeT + +

Normally, the conf i gur e script needs to be running under the graphical environment
(X11) in order to test for wi sh, the Tcl/Tk shell. If you are logged in via an ssh session,
or there is some other reason why X is not running, the easiest way to work around
the problem is to tell OMNeT + + to build without Tcl/Tk. To do that, use the command

$ NO TCL=1 ./configure

instead of plain . / conf i gure.

If there is an error during confi gur e, the output may give hints about what went
wrong, Scroll up to see the messages. (Use Shift+PgUp; you may need to increase the
scrollback buffer size of the terminal and re-run . / conf i gur e.) The script also writes
a very detailed log of its operation into confi g. | og to help track down errors. Since
confi g. | og is very long, it is recommended that you open it in an editor and search
for phrases like error or the name of the package associated with the problem.

TE
NOE

The conf i gur e script tries to build and run small test programs that are using specific
libraries or features of the system. You can check the confi g. | og file to see which
test program has failed and why. In most cases the problem is that the script cannot
figure out the location of a specific library. Specifying the include file or library location

29



Generic Unix

in the confi gur e. user file and then re-running the conf i gur e script usually solves
the problem.

When . / conf i gur e has finished, you can compile OMNeT+ +. Type in the terminal:

$ nake

‘@ DNt UNT U ESKTO P =] =701 [l [ i3]
File Edit VWiew Terminal Tabs Help

g++ -c -g -Wall -fno-stack-protector  -DXMLPARSER=Libxml -DWITH PARSIM —DWITH_NFH
ETBUILDER -I. -Ihtdocs -I/home/ubuntu/omnest-4.0/include -o out/gcc-debug//Http
Msg _m.o HttpMsg m.cc

g++ -c -g -Wall -fno-stack-protector  -DXMLPARSER=Libxml -DWITH_ PARSIM -DWITH N
ETBUILDER -I. -Ihtdocs -I/home/ubuntu/omnest-4.8/include -o out/gcc-debug//NetP
kt_m.o NetPkt_m.cc

g++ -c -g -Wall -fno-stack-protector  -DXMLPARSER=Libxml -DWITH PARSIM -DWITH N
ETBUILDER -I. -Ihtdocs -I/home/ubuntu/omnest-4.0/include -o out/gcc-debug//Teln
etPkt_m.o TelnetPkt_m.cc

g++ -Wl,--export-dynamic -WL,-rpath,/home/ubuntu/omnest-4.08/1ib:. -0 out/gcc-de
bug//sockets out/gcc-debug//Cloud.o out/gcc-debug//ExtHttpClient.o out/gcc-debu
g//ExtTelnetClient.o out/gcc-debug//HttpClient.o out/gcc-debug//HttpServer.o out
/gcc-debug//QueueBase.o out/gcc-debug//SocketRTScheduler.o out/gcc-debug//Telnet
Client.o out/gcc-debug//TelnetServer.o out/gcc-debug//HttpMsg m.o out/gcc-debug/
/NetPkt_m.o out/gcc-debug//TelnetPkt m.o -Wl,--whole-archive -Wl,--no-whole-ar
chive -L"/home/ubuntu/omnest-4.8/1ib/gcc" -L"/home/ubuntu/omnest-4.8/1ib" -u _tk|
env_1ib -lopptkenvd -loppenvird -lopplayoutd -u _cmdenv_1lib -loppcmdenvd -loppen
vird -loppsimd -1dl -lstdc++

1n -s -f out/gcc-debug//sockets .

make[2]: Leaving directory " /home/ubuntu/omnest-4.0/samples/sockets’

make[1]: Leaving directory "/home/ubuntu/omnest-4.0'

[»

Mow you can type "omnest" to start the IDE
ubuntu@ubuntu-desktop:~/omnest-4.0%

Figure 9.2. Building OMNeT+ +

To take advantage of multiple processor cores, add the -j 2 option to the make
- command line.

The build process will not write anything outside its directory, so no special privileges

NOTE
= are needed.

The make command will seemingly compile everything twice. This is because both
- debug and optimized versions of the libraries are built. If you only want to build one
set of the libraries, specify MODE=debug or MODE=r el ease:

$ make MODE=r el ease

9.7. Verifying the Installation

You can now verify that the sample simulations run correctly. For example, the dyna
simulation is started by entering the following commands:

$ cd sanpl es/ dyna
$ ./dyna

By default, the samples will run using the Tcl/Tk environment. You should see nice gui
windows and dialogs.

9.8. Starting the IDE

% The IDE is supported only on Windows, Mac OS X (x86) and Linux (x86,x64).
WS
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You can run the IDE by typing the following command in the terminal:

SimuIation SOMNESTIDES (==

Fle Edit Source Navigate Search Project Run Window Help

SRy " @
L(5 Project Explorer 32 =0 =0

B & <

T aloha

TIcgn

Tidyna

1 embedding

T embedding2

cafifo

T histograms

[ Properties 8 Gz Outline, = 8

Properties are not available,

[£l Problerns 88 . [ Module Hierarchy i3 NED Parameters | T2 NED Inheritance ¥ =8

0 items

Ind 0 items selected @ 9 = o

Figure 9.3. The Simulation IDE

If you would like to be able to access the IDE from the application launcher or via a
desktop shortcut, run one or both of the commands below:

$ make install-nmenu-item
$ make install-desktop-icon

—E The above commands assume that your system has the xdg commands, which most
= modern distributions do.

9.9. Optional Packages
9.9.1. Akaroa

If you wish to use Akaroa, it must be downloaded, compiled, and installed manually
before installing OMNeT ++.

As of version 2.7.9, Akaroa only supports Linux and Solaris.
note

Download Akaroa 2.7.9 from: http://www.cosc.canterbury.ac.nz/research/RG/net_sim/
simulation_group/akaroa/download.chtml

Extract it into a temporary directory:
$ tar xfz akaroa-2.7.9.tar.gz

Configure, build and install the Akaroa library. By default, it will be installed into the
/usr /| ocal / akar oa directory.

$ ./configure
$ nake
$ sudo meke install

Go to the OMNeT++ directory, and (re-)run the confi gure script. Akaroa will be
automatically detected if you installed it to the default location.
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9.9.2. PCAP

The optional Pcap library allows simulation models to capture and transmit network
packets bypassing the operating system’'s protocol stack. It is not used directly by

OMNeT++, but OMNeT++ detects the necessary compiler and linker options for
models in case they need it.
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Chapter 10. Build Options

10.1. Configure.user Options

The confi gure. user file contains several options that can be used to fine-tune the

simulation libraries.

You always need to re-run the conf i gur e script in the installation root after changing

the confi gur e. user file.

$ ./configure

After this step, you have to remove all previous libraries and recompile OMNeT + +:

$ make cl eanal |
$ nake

Options:

<COVPONENTNAME>_ CFLAGS,
<COVPONENTNAME>_LI BS

W TH_PARSI M=no

W TH_NETBUI LDER=n0

NO TCL=yes

EMBED_TCL_CODE=no

The configure.user file contains variables for
defining the compile and link options needed by
various external libraries. By default, the confi gure
command detects these automatically, but you
may override the auto detection by specifying
the values by hand. (e.g. <COWP>_CFLAGS=-1/
pat h/to/ conp/i ncludedir and <COWP>_LI| BS=-
L/ path/to/ conmp/libdir -lnaneoflib.)

Use this variable to explicitly disable parallel
simulation support in OMNeT+ +.

This option allows you to leave out the NED language
parser and the network builder. (This is needed only
if you are building your network with C++ API calls
and you do not use the built-in NED language parser
at all.)

This will prevent the build system to link with Tel/
Tk libraries. Use this option if your platform does not
have a suitable Tcl/Tk package and you will run the
simulation only in command line mode. (i.e. You want
to run OMNeT+ + in a remote terminal session.)

Tcl/Tk is a script language and the source of the
graphical runtime environment is stored as . t ¢l files
in the sr ¢/ t kenv directory. By default, these files are
not used directly, but are embedded as string literals
in the executable file. Setting EMBED_TCL_CODE=yes
allows you to move the OMNeT++ installation
without caring about the location of the .tcl
files. If you want to make changes to the Tcl
code, you better switch off the embedding with
the EMBED TCL_CODE=no option. This way you can
make changes to the . tcl files and see the changes
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CFLAGS [ RELEASE/ DEBUG

LDFLAGS

SHARED LI BS

immediately without recompiling the OMNeT++
libraries.

To change the compiler command line options
the build process is using, you should specify
them in the CFLAGS_RELEASE and CFLAGS_DEBUG
variables. By default, the flags required for
debugging or optimization are detected automatically
by the configure script. If you set them
manually, you should specify all options you
need. It is recommended to check what
options are detected automatically (check the
Makefile.inc after running configure and
look for the CFLAGS [ RELEASE/ DEBUG variables.)
and add/modify those options manually in the
confi gure. user file.

Linker command line options can be explicitly set
using this variable. It is recommended to check
what options are detected automatically (check the
Makefi | e. i nc after running conf i gur e and look for
the LDFLAGS variable.) and add/modify those options
manually in the confi gur e. user file.

This variable controls whether the OMNeT+ + build
process will create static or dynamic libraries. By
default, the OMNeT++ runtime is built as shared
libraries. If you want to build a single executable
from your simulation, specify SHARED LI BS=no
in configure.user to create static OMNeT++
libraries and then reconfigure (./confi gure) and
recompile OMNeT++ (make cl eanal | ; make). Once
the OMNeT + + static libraries are correctly built, your
own project have to be rebuilt, too. You will get a
single, statically linked executable, which requires
only the NED and INI files to run.

It is important to completely delete the OMNeT+ + libraries (make cl eanal | ) and
then rebuild them, otherwise it cannot be guaranteed that the created simulations are
linked against the correct libraries.

The following symbols can be defined for the compiler if you need backward
compatibility with some older OMNeT+ + 3.x features. They should be specified on the
compiler command line using the - DSYMBOLNAME syntax. You can add these options

to the CFLAGS_RELEASE or

CFLAGS_DEBUG variables (e.g. CFLAGS_RELEASE="' - O2 -

DNDEBUG=1 - DSYMBOLNANME' ).

USE_DOUBLE_SI MTI NE

W THOUT_CPACKET

OMNeT++ 3.x used doubl e as the type for simulation
time. In OMNeT++ 4.0 and later, the simulation time is
a fixed-point number based on a 64-bit integer.. If you
want to work with doubl e simulation time for some reason
(e.g. during porting an OMNeT+ + 3.x model), define the
USE_DOUBLE_SI Ml ME symbol for the compiler.

In OMNeT++ 3.x, methods and data related to the
modeling of network packets were included in the
cMessage class. For these parameters, OMNeT++ 4.x
has a new class called cPacket (derived from cMessage).
If you want get back the old behavior (i.e. having a
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single cMessage class only), define the W THOUT_CPACKET
symbol.

10.2. Moving the Installation

When you build OMNeT++ on your machine, several directory names are compiled
into the binaries. This makes it easier to set up OMNeT+ + in the first place, but if you
rename the installation directory or move it to another location in the file system, the
built-in paths become invalid and the correct paths have to be supplied via environment

variables.

The following environment variables are affected (in addition to PATH, which also needs

to be adjusted):

OWNETPP_| MAGE_PATH

OVNETPP_TKENV_DI R

LD_LI BRARY_PATH

TE
note

are present.

This variable contains the list of directories where Tkenv
looks for icons. Set it to point to the i nages/ subdirectory
of your OMNeT+ + installation.

This variable points to the directory that contains the Tcl
script parts of Tkenv, which is by default the src/t kenv/
subdirectory of your OMNeT++ installation. Normally
you don’'t need to set this variable, because the Tkenv
shared library contains all Tcl code compiled in as
string literals. However, if you compile OMNeT++ with
the EMBED_TCL_CODE=no setting and then you move the
installation, then you need to set OVNETPP_TKENV_DI R,
otherwise Tkenv won't start.

This variable contains the list of additional directories
where shared libraries are looked for. Initially,
LD LI BRARY_PATHis not needed because shared libraries
are located via the rpath mechanism. When you move the
installation, you need to add the | i b/ subdirectory of your
OMNeT+ + installation to LD LI BRARY _PATH.

On Mac OS X, DYLD LI BRARY_PATH is used instead of LD LI BRARY_ PATH. On
Windows, the PATH variable must contain the directory where shared libraries (DLLs)

10.3. Using Different Compilers

By default, the configure script detects the following compilers automatically in the

path:

* Intel compiler (icc, icpc)

« GNU C/C++ (gcc, g++)

¢ Sun Studio (cc, cxx)

* IBM compiler (xlc, xIC)

If you want to use compilers other than the above ones, you should specify the compiler
name in the CC and CXX variables, and re-run the configuration script.

NOTE

Different compilers may have different command line options. If you use a compiler

— other than the default gcc, you may have to revise the CFLAGS_[ RELEASE/ DEBUG
- and LDFLAGS variables.
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